Zero alcohol in the wash?

Just starting out and need some advise? then post it in here.

Zero alcohol in the wash?

Postby Outbackozzie » Sat Apr 23, 2022 2:00 pm

Gday, just racked the first wash from one of my fermenters (Fermzilla) - and the Alcometer is showing 0% alcohol :shock:

It fermented exactly the same amount of time as the normal ferment barrel beside it, but smells different to previous washes I have done - not nasty, but different.

I am not able to test PH.

The wash is a normal sugar wash, with 1/3 packet turbo yeast ( I know, just using it up) and a spoon of nutrient from HBS to make up for the lack of Turbo sachet.

Curious, but still going to run it with a couple of litres of tails added in the boiler. This brought the alcohol content up to zero still….
Tested the alcometer on a 40% test tube and it reads fine.

This will be like my 15th stilling run, so it’s weird.

I will report back if anything comes out :)
Outbackozzie
 
Posts: 19
Joined: Sat Apr 09, 2022 12:19 pm
equipment: T500, alembic.

Re: Zero alcohol in the wash?

Postby bluc » Sat Apr 23, 2022 2:24 pm

You cant use an alcometer in wash. You need a hydrometer.
Will show a reading in sg not a % alcohol.. take a gravity at start one at end then punch into the site calculator. It will tell you % alcohol. :handgestures-thumbupleft:
Last edited by bluc on Sat Apr 23, 2022 2:27 pm, edited 2 times in total.
bluc
Site Donor
 
Posts: 8614
Joined: Tue Apr 14, 2015 5:47 pm
Location: sunshine coast
equipment: 2" pot with 2" shotty 400mm long 5x 1/2" on a t500 boiler.
50l keg boiler 4" still mount 4" sight glass 1" drain..
4 plate 4" bubbler, 600mm packed section

Re: Zero alcohol in the wash?

Postby Outbackozzie » Sat Apr 23, 2022 2:44 pm

Thanks.
Outbackozzie
 
Posts: 19
Joined: Sat Apr 09, 2022 12:19 pm
equipment: T500, alembic.


Return to Beginners Questions



Who is online

Users browsing this forum: No registered users and 5 guests

cron

x